管理接口與管理IP地址

 


前言

當用戶希望對設備進行管理時,需要藉助管理接口和管理IP地址。
本文檔介紹了交換機支持的管理接口以及如何配置管理IP地址。

01管理接口

常見的設備管理方式有SNMP、Web、Telnet以及通過Console口管理等。
從技術的角度分析,網絡管理可分為帶外管理和帶內管理。
所謂帶內管理,是指網絡中的管理數據和業務數據在相同的鏈路中傳輸。
當管理數據的流量較少時,對整個網絡的性能影響不明顯,可採用帶內管理。
所謂帶外管理,是指網絡中的管理數據與業務數據在不同的鏈路中傳輸。
通過專門的網管通道實現對網絡的管理可提高網絡管理的效率與可靠性,
也有利於提高網管數據的安全性。
用戶要實現對設備的管理,首先要連接設備的管理接口。
交換機當前支持的管理接口包括Console口、MiniUSB口、
管理網口和業務口,下面將逐一進行介紹。用戶可以根據實際需求,進行合理選擇。

1.1 Console口

通過Console口登錄設備適用於首次登錄交換機或無法遠程登錄交換機,
以及設備無法啟動的場景。
通過Console口登錄設備是指使用專門的Console通信線纜將用戶PC的串口與交換機的Console口相連,
在進行相應的配置後實現在本地管理交換機,該方式是登錄交換機最基本的方式,
屬於帶外管理,也是其他登錄方式(如Telnet、STelnet)的基礎。
PC與交換機的具體連接方式如圖1所示。

1.2 MiniUSB口

當用戶終端PC沒有可用Console口時,
也可以使用MiniUSB線纜將PC的USB口連接到設備的MiniUSB口進行登錄,
從而實現對首次登錄的設備進行基本配置和管理。
通過MiniUSB口登錄與通過Console口登錄僅設備的連接方式不同,
登錄時的通訊參數和登錄配置是一致的,
也屬於帶外管理。當MiniUSB口和Console口同時使用時,
只有MiniUSB口生效。 PC與交換機的具體連接方式如圖2所示。

1.3 管理網口

管理網口是一種特殊的以太網接口,可以配置IP地址,但不承擔業務傳輸。
該方式屬於帶外管理。交換機設備面板上的ETH口為管理網口,
但盒式交換機的管理網口的軟件接口名稱是MEth接口,
框式交換機的管理網口的軟件接口名稱是ETH接口。
PC與交換機的具體連接方式如圖3所示。

1.4 業務口

業務口指的是承擔業務傳輸的以太網接口。
當通過業務口對設備進行配置管理時,
網絡中的管理數據和業務數據在相同的鏈路中傳輸,即採用帶內管理。
PC與交換機的具體連接方式如圖4所示。

02配置管理IP地址

管理IP可在管理網口上配置,也可在業務口上配置。
對於管理網口,可直接在該接口上配置IP地址。
對於業務口,若設備支持二三層模式切換,在接口切換到三層模式後,
可直接在三層接口上配置IP地址;否則,設備可藉助VLANIF接口配置IP地址。
下面將分別介紹如何在管理網口或業務口上配置管理IP地址,
以及如何查看接口IP地址。

2.1 在管理網口上配置管理IP地址

對於盒式交換機

【1】執行命令interface MEth 0/0/1,進入MEth接口視圖。

system-view
[HUAWEI] interface MEth 0/0/1

【2】執行命令ip address ip-address{ mask | mask-length },
配置MEth接口的IP地址。此處假設設備管理網口的IP地址為10.1.1.1/24。

[HUAWEI-MEth0/0/1] ip address 10.1.1.1 24

對於框式交換機

【1】執行命令interface Ethernet 0/0/0,進入ETH接口視圖。

system-view
[HUAWEI] interface Ethernet 0/0/0

【2】執行命令ip addressip-address { mask | mask-length },

配置ETH接口的IP地址。此處假設設備管理網口的IP地址為10.1.1.2/24。

[HUAWEI-Ethernet0/0/0] ip address 10.1.1.2 24]

2.2 在業務口上配置管理IP地址

通過三層接口進行配置

【1】執行命令interfaceinterface-type interface-number,
進入以太網接口視圖。此處假設設備連接PC的接口是GigabitEthernet0/0/1。

system-view
[HUAWEI] interface GigabitEthernet 0/0/1

【2】執行命令undo portswitch,配置接口切換到三層模式。
缺省情況下,以太網接口工作在二層模式。

[HUAWEI-GigabitEthernet0/0/1] undo portswitch

【3】執行命令ip address ip-address { mask | mask-length },
配置接口的IP地址。此處假設三層接口的IP地址為10.1.1.3/24。

[HUAWEI-GigabitEthernet0/0/1] ip address 10.1.1.3 24
2.3 通過VLANIF接口進行配置

【1】執行命令interfaceinterface-type interface-number,
進入以太網接口視圖。此處假設設備連接PC的接口是GigabitEthernet0/0/1。

system-view
[HUAWEI] interface GigabitEthernet 0/0/1

【2】執行命令port link-type access配置接口類型為access。

[HUAWEI-GigabitEthernet0/0/1] port link-type access

【3】執行命令port default vlan vlan-id,
配置接口的缺省VLAN並將接口加入到指定VLAN。

[HUAWEI-GigabitEthernet0/0/1] port default vlan 4094
[HUAWEI-GigabitEthernet0/0/1] quit

【4】執行命令interface Vlanif vlan-id,
創建VLANIF接口並進入VLANIF接口視圖。

[HUAWEI] interface Vlanif 4094

【5】執行命令ip address ip-address { mask | mask-length },
配置VLANIF接口的IP地址。此處假VLANIF接口的IP地址為10.1.1.4/24。

[HUAWEI-Vlanif4094] ip address 10.1.1.4 24

03如何查看管理IP地址

執行命令display ip interface [ interface-type interface-number ] ],
查看接口與IP相關的信息。在接口上配置的IP地址可查看Internet Address is字段信息。

執行命令display ip interface brief
[ interface-type [ interface-number ] | slotslot-id [ cardcard-number ] ],
查看接口與IP相關的摘要信息。在接口上配置的IP地址可查看IP Address/Mask字段信息。

執行命令display interface [ interface-type interface-number ],
查看接口信息。在接口上配置的IP地址可查看Internet Address is字段信息。



發佈留言